Squash Docs
Search…
System Requirments
System requirements for Squash 3
Squash 3 requires macOS Big Sur or newer and is available via the Realmac Software Online Store or via Setapp.

System Requirments

  • Squash 3 Requires macOS 10.14 Big Sur or newer.
  • Squash 3 is a universal app and runs natively on Intel and Apple Silicon M1 Macs.
Copy link